#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)--cors-allowed-origins='https://mydomain-[a-zA-Z0-9]+\.app(?: https://mydomain-[a-zA-Z0-9]+.app)?'"
Local $sString = "--cors-allowed-origins='https://mydomain-yes801.app https://mydomain-yes802.app'" & @CRLF & _
"--cors-allowed-origins='https://mydomain-yes801.app'"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")