const regex = new RegExp('--cors-allowed-origins=\\'https://mydomain-[a-zA-Z0-9]+\\.app(?: https://mydomain-[a-zA-Z0-9]+.app)?\\'', 'gm')
const str = `--cors-allowed-origins='https://mydomain-yes801.app https://mydomain-yes802.app'
--cors-allowed-origins='https://mydomain-yes801.app'`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}