$re = '`--cors-allowed-origins=\'https://mydomain-[a-zA-Z0-9]+\.app(?: https://mydomain-[a-zA-Z0-9]+.app)?\'`m';
$str = '--cors-allowed-origins=\'https://mydomain-yes801.app https://mydomain-yes802.app\'
--cors-allowed-origins=\'https://mydomain-yes801.app\'';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);