// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)--cors-allowed-origins='https://mydomain-[a-zA-Z0-9]+\.app(?: https://mydomain-[a-zA-Z0-9]+.app)?'").unwrap();
let string = "--cors-allowed-origins='https://mydomain-yes801.app https://mydomain-yes802.app'
--cors-allowed-origins='https://mydomain-yes801.app'";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}