re = /--cors-allowed-origins='https:\/\/mydomain-[a-zA-Z0-9]+\.app(?: https:\/\/mydomain-[a-zA-Z0-9]+.app)?'/m
str = '--cors-allowed-origins=\'https://mydomain-yes801.app https://mydomain-yes802.app\'
--cors-allowed-origins=\'https://mydomain-yes801.app\''
# Print the match result
str.scan(re) do |match|
puts match.to_s
end