using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"--cors-allowed-origins='https://mydomain-[a-zA-Z0-9]+\.app(?: https://mydomain-[a-zA-Z0-9]+.app)?'";
string input = @"--cors-allowed-origins='https://mydomain-yes801.app https://mydomain-yes802.app'
--cors-allowed-origins='https://mydomain-yes801.app'";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}