#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m).*\b\d\b.*"
Local $sString = "Привет я был в 2часа" & @CRLF & _
"Сегодня в2 часа" & @CRLF & _
"Сегодня вчаса2 " & @CRLF & _
"Это было в2часа" & @CRLF & _
"Привет он был в 2 часа" & @CRLF & _
"Привет я был в 22часа" & @CRLF & _
"Сегодня в22 часа" & @CRLF & _
"2 часа не было меня" & @CRLF & _
"22 часа не было меня" & @CRLF & _
"Это было в22часа" & @CRLF & _
"Привет он был в 22 часа" & @CRLF & _
"2" & @CRLF & _
"22" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")