import Foundation
let pattern = #".*\b\d\b.*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Привет я был в 2часа
Сегодня в2 часа
Сегодня вчаса2
Это было в2часа
Привет он был в 2 часа
Привет я был в 22часа
Сегодня в22 часа
2 часа не было меня
22 часа не было меня
Это было в22часа
Привет он был в 22 часа
2
22
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)