using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*\b\d\b.*";
string input = @"Привет я был в 2часа
Сегодня в2 часа
Сегодня вчаса2
Это было в2часа
Привет он был в 2 часа
Привет я был в 22часа
Сегодня в22 часа
2 часа не было меня
22 часа не было меня
Это было в22часа
Привет он был в 22 часа
2
22
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}