import re
regex = re.compile(r".*\b\d\b.*", flags=re.MULTILINE)
test_str = ("Привет я был в 2часа\n"
"Сегодня в2 часа\n"
"Сегодня вчаса2 \n"
"Это было в2часа\n"
"Привет он был в 2 часа\n"
"Привет я был в 22часа\n"
"Сегодня в22 часа\n"
"2 часа не было меня\n"
"22 часа не было меня\n"
"Это было в22часа\n"
"Привет он был в 22 часа\n"
"2\n"
"22\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")