$re = '/.*\b\d\b.*/m';
$str = 'Привет я был в 2часа
Сегодня в2 часа
Сегодня вчаса2
Это было в2часа
Привет он был в 2 часа
Привет я был в 22часа
Сегодня в22 часа
2 часа не было меня
22 часа не было меня
Это было в22часа
Привет он был в 22 часа
2
22
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);