#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)<TopicSet FormalName="PARENT1">(?:(?:\s|\S)*?)TopicType FormalName="(.+)"(?:(?:\s|\S)*?)<\/TopicSet>"
Local $sString = "<TopicSet FormalName="PARENT1">" & @CRLF & _
" <Topic>" & @CRLF & _
" <TopicType FormalName="Child1" />" & @CRLF & _
" </Topic>" & @CRLF & _
" <Topic>" & @CRLF & _
" <TopicType FormalName="Child2" />" & @CRLF & _
" </Topic>" & @CRLF & _
" <Topic>" & @CRLF & _
" <TopicType FormalName="Child3" />" & @CRLF & _
" </Topic>" & @CRLF & _
"</TopicSet>" & @CRLF & _
"<TopicSet FormalName="PARENT2">" & @CRLF & _
" <Topic>" & @CRLF & _
" <TopicType FormalName="Child1" />" & @CRLF & _
" </Topic>" & @CRLF & _
" <Topic>" & @CRLF & _
" <TopicType FormalName="Child2" />" & @CRLF & _
" </Topic>" & @CRLF & _
" <Topic>" & @CRLF & _
" <TopicType FormalName="Child3" />" & @CRLF & _
" </Topic>" & @CRLF & _
"</TopicSet>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")