import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<TopicSet FormalName=\"PARENT1\">(?:(?:\\s|\\S)*?)TopicType FormalName=\"(.+)\"(?:(?:\\s|\\S)*?)<\\/TopicSet>";
final String string = "<TopicSet FormalName=\"PARENT1\">\n"
+ " <Topic>\n"
+ " <TopicType FormalName=\"Child1\" />\n"
+ " </Topic>\n"
+ " <Topic>\n"
+ " <TopicType FormalName=\"Child2\" />\n"
+ " </Topic>\n"
+ " <Topic>\n"
+ " <TopicType FormalName=\"Child3\" />\n"
+ " </Topic>\n"
+ "</TopicSet>\n"
+ "<TopicSet FormalName=\"PARENT2\">\n"
+ " <Topic>\n"
+ " <TopicType FormalName=\"Child1\" />\n"
+ " </Topic>\n"
+ " <Topic>\n"
+ " <TopicType FormalName=\"Child2\" />\n"
+ " </Topic>\n"
+ " <Topic>\n"
+ " <TopicType FormalName=\"Child3\" />\n"
+ " </Topic>\n"
+ "</TopicSet>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}