// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)<TopicSet FormalName="PARENT1">(?:(?:\s|\S)*?)TopicType FormalName="(.+)"(?:(?:\s|\S)*?)<\/TopicSet>"#).unwrap();
let string = "<TopicSet FormalName=\"PARENT1\">
<Topic>
<TopicType FormalName=\"Child1\" />
</Topic>
<Topic>
<TopicType FormalName=\"Child2\" />
</Topic>
<Topic>
<TopicType FormalName=\"Child3\" />
</Topic>
</TopicSet>
<TopicSet FormalName=\"PARENT2\">
<Topic>
<TopicType FormalName=\"Child1\" />
</Topic>
<Topic>
<TopicType FormalName=\"Child2\" />
</Topic>
<Topic>
<TopicType FormalName=\"Child3\" />
</Topic>
</TopicSet>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}