using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\\VendNo (?<VendorID>[\w\d]+) InvNo (?<InvoiceID>.*)\.(?<Ext>\w+)$";
string input = @"I:\APInvoices\COMPANY1\VendNo V001 InvNo 100091.tif";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}