const regex = /\\VendNo (?<VendorID>[\w\d]+) InvNo (?<InvoiceID>.*)\.(?<Ext>\w+)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\\\VendNo (?<VendorID>[\\w\\d]+) InvNo (?<InvoiceID>.*)\\.(?<Ext>\\w+)$', 'gm')
const str = `I:\\APInvoices\\COMPANY1\\VendNo V001 InvNo 100091.tif`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}