re = /\\VendNo (?<VendorID>[\w\d]+) InvNo (?<InvoiceID>.*)\.(?<Ext>\w+)$/m
str = 'I:\\APInvoices\\COMPANY1\\VendNo V001 InvNo 100091.tif'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end