import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\\\VendNo (?<VendorID>[\\w\\d]+) InvNo (?<InvoiceID>.*)\\.(?<Ext>\\w+)$";
final String string = "I:\\APInvoices\\COMPANY1\\VendNo V001 InvNo 100091.tif";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}