// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\\VendNo (?<VendorID>[\w\d]+) InvNo (?<InvoiceID>.*)\.(?<Ext>\w+)$").unwrap();
let string = "I:\\APInvoices\\COMPANY1\\VendNo V001 InvNo 100091.tif";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}