$re = '/\\\\VendNo (?<VendorID>[\w\d]+) InvNo (?<InvoiceID>.*)\.(?<Ext>\w+)$/m';
$str = 'I:\\APInvoices\\COMPANY1\\VendNo V001 InvNo 100091.tif';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);