#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)(^|\s|,|;|:|\.)(Test)($|\s|,|;|\.|\b)"
Local $sString = "This test is OK. Thistest should not be marked. TEST which should be marked.Test. <a href="" target="_blank">Test</a>.<a href="http://www.link.com">This test should not be marked</a>.Test"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")