$re = '/(^|\s|,|;|:|\.)(Test)($|\s|,|;|\.|\b)/mi';
$str = 'This test is OK. Thistest should not be marked. TEST which should be marked.Test. <a href="" target="_blank">Test</a>.<a href="http://www.link.com">This test should not be marked</a>.Test';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);