// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)(^|\s|,|;|:|\.)(Test)($|\s|,|;|\.|\b)").unwrap();
let string = "This test is OK. Thistest should not be marked. TEST which should be marked.Test. <a href=\"\" target=\"_blank\">Test</a>.<a href=\"http://www.link.com\">This test should not be marked</a>.Test";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}