const regex = /(^|\s|,|;|:|\.)(Test)($|\s|,|;|\.|\b)/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(^|\\s|,|;|:|\\.)(Test)($|\\s|,|;|\\.|\\b)', 'gmi')
const str = `This test is OK. Thistest should not be marked. TEST which should be marked.Test. <a href="" target="_blank">Test</a>.<a href="http://www.link.com">This test should not be marked</a>.Test`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}