use strict;
my $str = 'This test is OK. Thistest should not be marked. TEST which should be marked.Test. <a href="" target="_blank">Test</a>.<a href="http://www.link.com">This test should not be marked</a>.Test';
my $regex = qr/(^|\s|,|;|:|\.)(Test)($|\s|,|;|\.|\b)/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}