re = /(^|\s|,|;|:|\.)(Test)($|\s|,|;|\.|\b)/mi
str = 'This test is OK. Thistest should not be marked. TEST which should be marked.Test. <a href="" target="_blank">Test</a>.<a href="http://www.link.com">This test should not be marked</a>.Test'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end