#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[^0-9.,]+"
Local $sString = "8,8386 %" & @CRLF & _
"370878439,39 €" & @CRLF & _
"370,88 Mio. €" & @CRLF & _
"375962902,92 €" & @CRLF & _
"-375,963 Mio. €" & @CRLF & _
"+25,58 %" & @CRLF & _
"371 €" & @CRLF & _
"+370,88 Mio." & @CRLF & _
"€ 93,8 million" & @CRLF & _
"290.5 million" & @CRLF & _
"12.8" & @CRLF & _
"100" & @CRLF & _
"8,8386 %" & @CRLF & _
"17226720,27 €" & @CRLF & _
"371 million €" & @CRLF & _
"375.96 €"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")