import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[^0-9.,]+";
final String string = "8,8386 %\n"
+ "370878439,39 €\n"
+ "370,88 Mio. €\n"
+ "375962902,92 €\n"
+ "-375,963 Mio. €\n"
+ "+25,58 %\n"
+ "371 €\n"
+ "+370,88 Mio.\n"
+ "€ 93,8 million\n"
+ "290.5 million\n"
+ "12.8\n"
+ "100\n"
+ "8,8386 %\n"
+ "17226720,27 €\n"
+ "371 million €\n"
+ "375.96 €";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}