# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"[^0-9.,]+"
test_str = ("8,8386 %\n"
"370878439,39 €\n"
"370,88 Mio. €\n"
"375962902,92 €\n"
"-375,963 Mio. €\n"
"+25,58 %\n"
"371 €\n"
"+370,88 Mio.\n"
"€ 93,8 million\n"
"290.5 million\n"
"12.8\n"
"100\n"
"8,8386 %\n"
"17226720,27 €\n"
"371 million €\n"
"375.96 €")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.