use strict;
my $str = '8,8386 %
370878439,39 €
370,88 Mio. €
375962902,92 €
-375,963 Mio. €
+25,58 %
371 €
+370,88 Mio.
€ 93,8 million
290.5 million
12.8
100
8,8386 %
17226720,27 €
371 million €
375.96 €';
my $regex = qr/[^0-9.,]+/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}