using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[^0-9.,]+";
string input = @"8,8386 %
370878439,39 €
370,88 Mio. €
375962902,92 €
-375,963 Mio. €
+25,58 %
371 €
+370,88 Mio.
€ 93,8 million
290.5 million
12.8
100
8,8386 %
17226720,27 €
371 million €
375.96 €";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}