re = /[^0-9.,]+/m
str = '8,8386 %
370878439,39 €
370,88 Mio. €
375962902,92 €
-375,963 Mio. €
+25,58 %
371 €
+370,88 Mio.
€ 93,8 million
290.5 million
12.8
100
8,8386 %
17226720,27 €
371 million €
375.96 €'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end