const regex = /[a-z]ass/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[a-z]ass', 'g')
const str = `aasstrail zassone `;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);