use strict;
my $str = 'aasstrail zassone ';
my $regex = qr/[a-z]ass/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";