# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\.\s+(\d+)/.\n$1/g;t' <<< "1. foo. 2. bar. 3. baz."