#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\.\s+(\d+)"
Local $sString = "1. foo. 2. bar. 3. baz."
Local $sSubst = ".\n$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)