$re = '/\.\s+(\d+)/';
$str = '1. foo. 2. bar. 3. baz.';
$subst = ".\n$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;