import Foundation
let pattern = #"\.\s+(\d+)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"1. foo. 2. bar. 3. baz."#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #".\n$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)