use strict;
my $str = '1. foo. 2. bar. 3. baz.';
my $regex = qr/\.\s+(\d+)/p;
my $subst = '.\\n$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";