package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(.+)(?:((?i)\sends\s[1]?[0-9]\s[ap]\.m\.))$`)
var str = `The Monkey Ends 9 P.M.
The Elefant Ends 12 A.M.
The Zebra Ends 2 P.M.
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}