// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(.+)(?:((?i)\sends\s[1]?[0-9]\s[ap]\.m\.))$").unwrap();
let string = "The Monkey Ends 9 P.M.
The Elefant Ends 12 A.M.
The Zebra Ends 2 P.M.
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}