import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(.+)(?:((?i)\\sends\\s[1]?[0-9]\\s[ap]\\.m\\.))$";
final String string = "The Monkey Ends 9 P.M.\n"
+ "The Elefant Ends 12 A.M.\n"
+ "The Zebra Ends 2 P.M.\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}