$re = '/(.+)(?:((?i)\sends\s[1]?[0-9]\s[ap]\.m\.))$/m';
$str = 'The Monkey Ends 9 P.M.
The Elefant Ends 12 A.M.
The Zebra Ends 2 P.M.
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);