re = /(.+)(?:((?i)\sends\s[1]?[0-9]\s[ap]\.m\.))$/m
str = 'The Monkey Ends 9 P.M.
The Elefant Ends 12 A.M.
The Zebra Ends 2 P.M.
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end