#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:\+\d{1,3}|\d{2,3})$"
Local $sString = "01" & @CRLF & _
"+1" & @CRLF & _
"00" & @CRLF & _
"99" & @CRLF & _
"999" & @CRLF & _
"+999" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"-1" & @CRLF & _
"9999" & @CRLF & _
"--1" & @CRLF & _
"+1+" & @CRLF & _
"0" & @CRLF & _
"+" & @CRLF & _
"-" & @CRLF & _
"1" & @CRLF & _
"99999" & @CRLF & _
"-1234"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")