$re = '/^(?:\+\d{1,3}|\d{2,3})$/m';
$str = '01
+1
00
99
999
+999
-1
9999
--1
+1+
0
+
-
1
99999
-1234';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);