package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:\+\d{1,3}|\d{2,3})$`)
var str = `01
+1
00
99
999
+999
-1
9999
--1
+1+
0
+
-
1
99999
-1234`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}