re = /^(?:\+\d{1,3}|\d{2,3})$/m
str = '01
+1
00
99
999
+999
-1
9999
--1
+1+
0
+
-
1
99999
-1234'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end