import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:\\+\\d{1,3}|\\d{2,3})$";
final String string = "01\n"
+ "+1\n"
+ "00\n"
+ "99\n"
+ "999\n"
+ "+999\n\n\n"
+ "-1\n"
+ "9999\n"
+ "--1\n"
+ "+1+\n"
+ "0\n"
+ "+\n"
+ "-\n"
+ "1\n"
+ "99999\n"
+ "-1234";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}