// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:\+\d{1,3}|\d{2,3})$").unwrap();
let string = "01
+1
00
99
999
+999
-1
9999
--1
+1+
0
+
-
1
99999
-1234";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}